cURL/libcurl 7.x < 7.50.3 RCE

High Nessus Network Monitor Plugin ID 9825


The host is running a version of cURL/libcurl that is vulnerable to a remote code execution (RCE) attack vector.


Versions of cURL and libcurl prior to 7.50.3 are affected by an integer overflow condition in the 'curl_escape()', 'curl_easy_escape()', 'curl_unescape()', and 'curl_easy_unescape()' functions in 'lib/escape.c' that is triggered when handling overly long string lengths. This may allow a context-dependent attacker to cause a heap-based buffer overflow, crashing a process linked against the library or potentially allowing the execution of arbitrary code.


Upgrade to cURL/libcurl 7.50.3 or later.

See Also

Plugin Details

Severity: High

ID: 9825

File Name: 9825.prm

Family: Web Clients

Published: 2016/12/09

Modified: 2016/12/09

Dependencies: 9772

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.9


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:haxx:curl

Patch Publication Date: 2016/09/14

Vulnerability Publication Date: 2016/09/14

Reference Information

CVE: CVE-2016-7167

BID: 92975