cURL/libcurl 7.x < 7.50.3 RCE

high Nessus Network Monitor Plugin ID 9825

Synopsis

The host is running a version of cURL/libcurl that is vulnerable to a remote code execution (RCE) attack vector.

Description

Versions of cURL and libcurl prior to 7.50.3 are affected by an integer overflow condition in the 'curl_escape()', 'curl_easy_escape()', 'curl_unescape()', and 'curl_easy_unescape()' functions in 'lib/escape.c' that is triggered when handling overly long string lengths. This may allow a context-dependent attacker to cause a heap-based buffer overflow, crashing a process linked against the library or potentially allowing the execution of arbitrary code.

Solution

Upgrade to cURL/libcurl 7.50.3 or later.

See Also

https://curl.haxx.se/docs/adv_20160914.html

Plugin Details

Severity: High

ID: 9825

Family: Web Clients

Published: 12/9/2016

Updated: 3/6/2019

Dependencies: 9772

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:haxx:curl:*:*:*:*:*:*:*:*

Patch Publication Date: 9/14/2016

Vulnerability Publication Date: 9/14/2016

Reference Information

CVE: CVE-2016-7167

BID: 92975