VLC Media Player 2.x < 2.2.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9798

Synopsis

The remote host contains a media application that is affected by multiple attack vectors.

Description

The remote host is running VLC 2.x prior to 2.2.1 and is affected by multiple vulnerabilities :

- A flaw exists that is triggered as user-supplied input is not properly validated when handling a specially crafted MP4 file. This may allow a context-dependent attacker to corrupt memory and potentially execute arbitrary code. (OSVDB 133862)
- An overflow condition exists that is triggered as user-supplied input is not properly validated when handling a WAV file. This may allow a context-dependent attacker to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (OSVDB 136501)

Solution

Upgrade to VLC Media Player 2.x version 2.2.1 or later.

See Also

http://www.videolan.org/vlc/releases/2.2.1.html

Plugin Details

Severity: High

ID: 9798

File Name: 9798.prm

Family: Web Clients

Published: 2016/11/18

Modified: 2016/12/06

Dependencies: 9797

Nessus ID: 91773

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.6

Temporal Score: 9.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2015/02/27

Vulnerability Publication Date: 2016/09/28

Reference Information

CVE: CVE-2016-3941

BID: 85752

OSVDB: 133862, 136501