Squid 3.5.x < 3.5.18 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9776


The remote proxy server is affected by multiple attack vectors.


Versions of Squid 3.5.x prior to 3.5.18 are affected by multiple vulnerabilities :

- A flaw is triggered as input is not properly validated when handling HTTP request messages. This may allow a remote attacker to conduct a cache poisoning attack. (OSVDB 138132)
- A flaw is triggered as input is not properly sanitized when handling specially crafted host headers. This may allow a remote attacker to bypass same-origin protection mechanisms and cause the program to contact the wrong origin server. This may also poison downstream caches. (OSVDB 138133)
- Flaws in pointer handling and reference counting are triggered when handling specially crafted ESI response syntax. This may allow a remote server to cause a denial of service for Squid clients. (OSVDB 138134)


Either upgrade to Squid version 3.5.18 or later, or apply the vendor-supplied patch.

See Also


Plugin Details

Severity: Medium

ID: 9776

File Name: 9776.prm

Family: Web Servers

Published: 2016/11/11

Modified: 2016/11/23

Dependencies: 3389

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Patch Publication Date: 2016/05/06

Vulnerability Publication Date: 2016/05/06

Reference Information

CVE: CVE-2016-4553, CVE-2016-4554, CVE-2016-4555, CVE-2016-4556

OSVDB: 138132, 138133, 138134