Squid 3.5.x < 3.5.18 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9776

Synopsis

The remote proxy server is affected by multiple attack vectors.

Description

Versions of Squid 3.5.x prior to 3.5.18 are affected by multiple vulnerabilities :

- A flaw is triggered as input is not properly validated when handling HTTP request messages. This may allow a remote attacker to conduct a cache poisoning attack.
- A flaw is triggered as input is not properly sanitized when handling specially crafted host headers. This may allow a remote attacker to bypass same-origin protection mechanisms and cause the program to contact the wrong origin server. This may also poison downstream caches.
- Flaws in pointer handling and reference counting are triggered when handling specially crafted ESI response syntax. This may allow a remote server to cause a denial of service for Squid clients.

Solution

Either upgrade to Squid version 3.5.18 or later, or apply the vendor-supplied patch.

See Also

http://www.squid-cache.org/Advisories/SQUID-2016_9.txt

Plugin Details

Severity: Medium

ID: 9776

Family: Web Servers

Published: 2016/11/11

Updated: 2019/03/06

Dependencies: 3389

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Patch Publication Date: 2016/05/06

Vulnerability Publication Date: 2016/05/06

Reference Information

CVE: CVE-2016-4553, CVE-2016-4554, CVE-2016-4555, CVE-2016-4556