cURL/libcurl 7.x < 7.48.0 Unknown Vulnerability

High Nessus Network Monitor Plugin ID 9761

Synopsis

The host is running a version of cURL/libcurl that is vulnerable to an unspecified attack vector.

Description

Versions of cURL and libcurl prior to 7.48.0 are affected by an integer overflow condition in the 'curlx_tvdiff()' function in 'lib/timeval.c'. The issue is triggered as user-supplied input is not properly validated when handling 'timeval'. This may allow a context-dependent attacker to have an unspecified impact.

Solution

Upgrade to cURL/libcurl 7.48.0 or later.

See Also

https://curl.haxx.se/changes.html#7_48_0

Plugin Details

Severity: High

ID: 9761

File Name: 9761.prm

Family: Web Clients

Published: 2016/11/11

Modified: 2016/11/23

Dependencies: 9772

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.4

Temporal Score: 7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:haxx:curl

Patch Publication Date: 2016/03/23

Vulnerability Publication Date: 2016/02/11