IBM WebSphere Application Server 8.5 < 8.5.5.7 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 9717
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running an application server that is vulnerable to multiple attack vectors.

Description

The remote host appears to be running IBM WebSphere Application Server 8.5 prior to 8.5.5.7. Such versions are potentially affected by multiple issues :

- An information disclosure vulnerability exists that allows an unauthenticated, remote attacker to identify the proxy server software by reading the HTTP 'Via' header. (CVE-2015-1932)
- An unspecified flaw exists that allows an unauthenticated, remote attacker to spoof servlets or disclose sensitive information. (CVE-2015-4938)

Solution

Upgrade WebSphere Application Server to 8.5.5.7 or later.

See Also

http://www-01.ibm.com/support/docview.wss?uid=swg27036319#8557

Plugin Details

Severity: Medium

ID: 9717

Family: Web Servers

Published: 10/26/2016

Updated: 3/6/2019

Dependencies: 4270

Nessus ID: 84639

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:ibm:websphere_application_server:*:*:*:*:*:*:*:*

Patch Publication Date: 9/11/2015

Vulnerability Publication Date: 9/11/2015

Reference Information

CVE: CVE-2015-4938, CVE-2015-1932

BID: 76463, 76466