Oracle MySQL 5.6.x < 5.6.33 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9614

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.33 and is affected by multiple issues :

- A flaw exists related to the way 'REPAIR TABLE' uses temporary files. This may allow an authenticated attacker to gain elevated privileges.
- A flaw exists in InnoDB that is triggered during the handling of an operation that dropped and created a full-text search table. This may allow an authenticated attacker to trigger an assertion and cause a denial of service.
- A flaw exists in InnoDB that is triggered when accessing full-text search auxiliary tables while dropping the indexed table. This may allow an authenticated attacker to trigger an assertion and cause a denial of service.
- An overflow condition exists that is triggered as certain input is not properly validated when handling long integer values in 'MEDIUMINT' columns. This may allow an authenticated attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code.
- A flaw exists that is triggered during the handling of prepared statements that use a parameter in the select list of a derived table that was part of a join. This may allow an authenticated attacker to crash the server.
- An unspecified flaw exists related to the Error Handling subcomponent. This may allow a local attacker to gain elevated privileges. No further details have been provided by the vendor.
- An unspecified flaw exists related to the MyISAM subcomponent. This may allow a local attacker to gain elevated privileges. No further details have been provided by the vendor.
- An unspecified flaw exists related to the GIS subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the Optimizer subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the Federated subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the InnoDB subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the Types subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.

Solution

Upgrade to MySQL 5.6.33 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-33.html

Plugin Details

Severity: High

ID: 9614

Family: Database

Published: 2016/09/30

Updated: 2019/03/06

Dependencies: 8914

Nessus ID: 93377, 93378

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2016/09/06

Vulnerability Publication Date: 2016/09/06

Reference Information

CVE: CVE-2016-3492, CVE-2016-5507, CVE-2016-5616, CVE-2016-5617, CVE-2016-5626, CVE-2016-5629, CVE-2016-8283

BID: 93614, 93737, 93638, 93650, 93668