Oracle MySQL 5.5.x < 5.5.50 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 9608

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.5.x prior to 5.5.50 and is affected by multiple issues :

- Multiple unspecified overflow conditions exist that are triggered as user-supplied input is not properly validated. This may allow an authenticated attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code.
- A NULL pointer dereference flaw exists in a parser structure that is triggered during the validation of stored procedure names. This may allow an authenticated attacker to potentially cause the database to crash.

Solution

Upgrade to MySQL 5.5.50 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-50.html

Plugin Details

Severity: High

ID: 9608

Family: Database

Published: 9/30/2016

Updated: 3/6/2019

Nessus ID: 91993, 91994

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:*

Patch Publication Date: 6/2/2015

Vulnerability Publication Date: 6/2/2016

Reference Information

CVE: CVE-2016-3477, CVE-2016-3521, CVE-2016-3615, CVE-2016-5440, CVE-2016-3452, CVE-2016-3471, CVE-2016-5444