OpenSSL 1.0.2 < 1.0.2f Information Disclosure

Low Nessus Network Monitor Plugin ID 9465

Synopsis

The remote web server is running an outdated instance of OpenSSL and that is affected by an Information Disclosure vulnerability.

Description

According to its banner, the version of OpenSSL on the remote host is 1.0.2 prior to 1.0.2f and is affected by a flaw in the 'DH_check_pub_key()' function in 'crypto/dh/dh_check.c' that is triggered when generating DH parameters based on unsafe primes. By completing multiple handshakes with a peer, a remote attacker can potentially disclose the peer's private DH exponent.

Solution

Upgrade OpenSSL to version 1.0.2f or higher.

See Also

https://www.openssl.org/news/secadv/20160128.txt

Plugin Details

Severity: Low

ID: 9465

Family: Web Servers

Published: 2016/08/05

Updated: 2019/03/06

Dependencies: 5563

Nessus ID: 89543

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2015/01/28

Vulnerability Publication Date: 2015/01/28

Reference Information

CVE: CVE-2016-0701

BID: 82233