Apache HTTP Server 2.4.x < 2.4.23 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9394

Synopsis

The remote web server is missing an Apache HTTP Server patch update.

Description

The version of Apache HTTP Server 2.4 installed on the remote host is prior to 2.4.23. It is, therefore, affected by the following vulnerabilities :

- A flaw exists within the 'read_request_line()' function located in 'server/protocol.c'. The issue is triggered when handling invalid 'CONNECT' requests with a custom status 'code 400 error' page using server side includes. With a specially crafted request, a remote attacker can cause a crash. (OSVDB-134423)
- A flaw can be triggered when a stream's flow control windows are manipulated. This may allow an authenticated remote attacker to block server threads for an extended period of time, allowing them to exhaust worker threads and prevent the processing of streams. (CVE-2016-1546) - A flaw is triggered when an experimental module for the 'HTTP/2' protocol is used to access a resource. This may result in X.509 certificates not being properly validated, allowing an unauthorized user to disclose potentially sensitive information in resources that should require valid certificates. (CVE-2016-4979)

Solution

Upgrade to Apache HTTP Server version 2.4.23 or later.

See Also

http://www.apache.org/dist/httpd/CHANGES_2.4.23

Plugin Details

Severity: Medium

ID: 9394

Family: Web Servers

Published: 2016/07/15

Modified: 2016/11/23

Dependencies: 8947

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Patch Publication Date: 2016/07/05

Vulnerability Publication Date: 2016/07/05

Reference Information

CVE: CVE-2016-1546, CVE-2016-4979

IAVA: 2016-A-0171