WordPress < 4.5.3 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9388

Synopsis

The remote server is hosting an outdated installation of WordPress that is affected by multiple vulnerabilities.

Description

Versions of WordPress prior to 4.5.3 are affected by multiple vulnerabilities :

- A flaw exists in Customizer, which may allow an attacker to perform a "redirect bypass".
- Multiple cross-site scripting (XSS) attacks exist because the program does not validate input when handling attachment names before returing it to users. This allows a remote attacker to craft a request that can execute arbitrary script in a user's browser session withing the trust relationship between their browser and the server.
- A flaw in the program may allow an attacker to gain access to potentially sensitive information in the revision history. No further details have been provided by the vendor.
- A flaw exists in oEmbed, which may allow a remote attacker to cause a denial of service. No further details have been provided by the vendor.
- The program contains a flaw which may allow an unauthorized attacker to remove categories from posts. No further details have been provided by the vendor.
- A flaw is triggered when handling stolen cookies. This may allow a remote attacker to make changes to passwords. No further details have been provided by the vendor.
- Multiple flaws exist related to 'sanitize_file_name()', which may allow an attacker to have an unspecified impact. No further details have been provided by the vendor.

Solution

Upgrade to WordPress 4.5.3 or later.

See Also

https://wordpress.org/news/2016/06/wordpress-4-5-3

Plugin Details

Severity: Medium

ID: 9388

Family: CGI

Published: 2016/07/07

Modified: 2018/09/16

Dependencies: 9035, 9036

Nessus ID: 91810

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Patch Publication Date: 2016/06/18

Vulnerability Publication Date: 2016/06/18