WordPress < 4.5.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 91810

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the WordPress application running on the remote web server is prior to 4.5.3.
It is, therefore, affected by the following vulnerabilities :

- An unspecified flaw exists in the Customizer component that allows an unauthenticated, remote attacker to perform a redirect bypass.

- Multiple cross-site scripting vulnerabilities exist due to improper validation of user-supplied input when handling attachment names. An unauthenticated, remote attacker can exploit these issues, via a specially crafted request, to execute arbitrary script code in a user's browser session.

- An information disclosure vulnerability exists that allows an unauthenticated, remote attacker to disclose revision history.

- An unspecified flaw exists in oEmbed that allows an unauthenticated, remote attacker to cause a denial of service condition.

- An unspecified flaw exists that allows an unauthenticated, remote attacker to remove categories from posts.

- An unspecified flaw exists that is triggered when handling stolen cookies. An unauthenticated, remote attacker can exploit this to change user passwords.

- Multiple unspecified flaws exist in the sanitize_file_name() function that allow an unauthenticated, remote attacker to have an unspecified impact.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress version 4.5.3 or later.

See Also

https://wordpress.org/news/2016/06/wordpress-4-5-3/

Plugin Details

Severity: Medium

ID: 91810

File Name: wordpress_4_5_3.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2016/06/24

Updated: 2019/04/01

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2016-5836

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2016/06/18

Vulnerability Publication Date: 2016/06/18

Reference Information

CVE: CVE-2016-5832, CVE-2016-5833, CVE-2016-5834, CVE-2016-5835, CVE-2016-5836, CVE-2016-5837, CVE-2016-5838, CVE-2016-5839

BID: 91362, 91363, 91364, 91365, 91366, 91367, 91368