Samba 3.x < 3.4.0 Buffer Overflow

High Nessus Network Monitor Plugin ID 9349

Synopsis

The remote Samba server is affected by a heap-based buffer overflow vulnerability.

Description

According to its banner, the version of Samba is 3.x earlier than 3.4.0. It is therefore affected by an overflow condition. The application fails to properly sanitize user-supplied input resulting in a heap-based buffer overflow. With a specially crafted 'Any Batched (AndX)' request packet, a remote attacker can potentially cause arbitrary code execution.

Solution

Upgrade Samba to version 3.4.0 or later.

See Also

http://www.samba.org/samba/security/CVE-2012-0870

https://www.samba.org/samba/history/samba-3.4.0.html

Plugin Details

Severity: High

ID: 9349

Family: Samba

Published: 2016/06/09

Modified: 2016/06/09

Dependencies: 8740

Nessus ID: 58327

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.9

Temporal Score: 6.9

Vector: CVSS2#AV:A/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2012/02/21

Vulnerability Publication Date: 2012/02/22

Reference Information

CVE: CVE-2012-0870

BID: 52103