Samba 4.x < 4.1.23 / 4.2.x < 4.2.9 / 4.3.x < 4.3.6 / 4.4.x < 4.4.0rc4 Multiple Vulnerabilities
Medium Nessus Network Monitor Plugin ID 9348
SynopsisThe remote Samba server is affected by multiple security issues.
DescriptionAccording to its banner, the version of Samba running on the remote host is 4.1.x prior to 4.1.23, 4.2.x prior to 4.2.9, 4.3.x prior to 4.3.6, or 4.4.0 prior to 4.4.0rc4. It is therefore affected by the following vulnerabilities :
- A security bypass vulnerability exists in the SMB1 implementation that is triggered when a symlink created to a file or directory using SMB1 UNIX extensions is accessed using non-UNIX SMB1 calls. An authenticated, remote attacker can exploit this to overwrite file and directory ACLs. (CVE-2015-7560)
- An out-of-bounds read error exists in the internal DNS server due to improper handling of TXT records when an AD DC is configured. An authenticated, remote attacker can exploit this, via a crafted DNS TXT record, to cause a crash or disclose memory contents. (CVE-2016-0771)
SolutionUpgrade Samba to version 4.4.0rc4 or later. If version 4.4.x cannot be obtained, versions 4.3.6, 4.2.9 and 4.1.23 are also patched for these issues.