Samba 3.3.x < 3.3.11 / 3.4.x < 3.4.6 / 3.5.x < 3.5.0rc3 Directory Traversal

High Nessus Network Monitor Plugin ID 9342


The remote Samba server is affected by a remote Denial of Service (DoS) attack vector.


According to its banner, the version of Samba is 3.3.x earlier than 3.3.11, or 3.4.x earlier than 3.4.6, or 3.5.x earlier than 3.5.0rc3, and is therefore affected by a directory-traversal vulnerability as the application fails to sufficiently sanitize user-supplied input. According to the vendor, the issue stems from an insecure default configuration. The vendor advises administrators to set 'wide links = no' in the '[global]' section of 'smb.conf'. To exploit this issue, attackers require authenticated access to a writable share, and may be exploited through a writable share accessible by guest accounts. This may allow an attacker to access files outside of the Samba user's root directory to obtain sensitive information and perform other attacks.


Upgrade Samba to version 3.5.0rc3 or later. If version 3.5.x cannot be obtained, versions 3.4.6 and 3.3.11 have also been patched for this issue.

See Also

Plugin Details

Severity: High

ID: 9342

Family: Samba

Published: 2016/06/09

Updated: 2019/03/06

Dependencies: 8740

Nessus ID: 44406

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2010/02/04

Vulnerability Publication Date: 2010/02/04

Reference Information

CVE: CVE-2010-0926

BID: 38111