Samba 2.2.x < 2.2.10 / 3.0.x < 3.0.5 Buffer Overflow

Medium Nessus Network Monitor Plugin ID 9339

Synopsis

The remote Samba server is affected by a buffer overflow attack vector.

Description

According to its banner, the version of Samba is 2.2.x earlier than 2.2.10, or 3.0.x earlier than 3.0.5, and is therefore affected by a flaw related to setting the option 'mangling method' to 'hash' in 'smb.conf' (which is not the default setting), and may allow an attacker to cause a buffer overflow. No further details have been provided.

Solution

Upgrade Samba to version 3.0.5 or later. If version 3.0.x cannot be obtained, version 2.2.10 has also been patched for this issue.

See Also

http://www.samba.org/samba/history/samba-2.2.10.html

http://www.samba.org/samba/history/samba-3.0.5.html

Plugin Details

Severity: Medium

ID: 9339

Family: Samba

Published: 2016/06/09

Modified: 2016/06/09

Dependencies: 8739, 8740

Nessus ID: 13657

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2004/07/22

Vulnerability Publication Date: 2004/07/22

Reference Information

CVE: CVE-2004-0686

BID: 10781