Apache ActiveMQ 5.x < 5.11.4, 5.12.x < 5.12.3, or 5.13.x < 5.13.2 XSS

Medium Nessus Network Monitor Plugin ID 9319

Synopsis

The remote host is running a web application that is affected by a Cross-Site Scripting (XSS) attack vector.

Description

Versions of Apache ActiveMQ 5.x prior to 5.11.4, 5.12.3, or 5.13.2 are affected by a flaw that is due to missing 'X-Frame-Options' headers in HTTP responses. This may potentially allow a context-dependent attacker to conduct a clickjacking attack.

Solution

Upgrade to ActiveMQ 5.13.2 or later. If version 5.13.x cannot be obtained, versions 5.12.3 and 5.11.4 have also been patched for this issue.

See Also

http://activemq.apache.org/security-advisories.data/CVE-2016-0782-announcement.txt

Plugin Details

Severity: Medium

ID: 9319

Family: CGI

Published: 2016/05/24

Modified: 2016/05/24

Dependencies: 8957

Nessus ID: 90024

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Patch Publication Date: 2015/03/10

Vulnerability Publication Date: 2015/03/10

Reference Information

CVE: CVE-2016-0782