MariaDB Server 10.1.x < 10.1.9 Multiple DoS Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9290

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 10.1.x earlier than 10.1.9, and is therefore affected by the following denial of service vulnerabilities :

- A flaw exists in the 'gis_field_options_read()' function in 'sql/field.cc' that is triggered during the handling of the GIS feature. This may allow an authenticated attacker to crash the database.
- A flaw exists in the 'init_read_record_idx()' function that is triggered when handling errors. This may allow an authenticated attacker to cause a denial of service.
- A flaw exists in the 'ACL_internal_schema_registry::lookup()' function in the file 'sql/sql_acl.cc' that is triggered during the handling of multi-table updates. This may allow an authenticated attacker to cause a crash.

Solution

Upgrade to version 10.1.9 or later.

See Also

https://mariadb.com/kb/en/mariadb-1019-release-notes

https://mariadb.atlassian.net/browse/MDEV-7762

https://mariadb.atlassian.net/browse/MDEV-8992

Plugin Details

Severity: Medium

ID: 9290

Family: Database

Published: 2016/05/13

Modified: 2018/09/16

Dependencies: 8693

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.5

Temporal Score: 6

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Patch Publication Date: 2015/10/23

Vulnerability Publication Date: 2015/10/22