VLC Media Player < 2.2.0 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9266

Synopsis

The remote host contains a media application that is affected by multiple vulnerabilities.

Description

The remote host is running VLC 2.x prior to 2.2.0 and is affected by multiple vulnerabilities :

- A buffer overflow exists in the VLC Update utility when handling overly large status files. Specifically, this affects the 'GetUpdateFile()' function in the source file 'src/misc/update.c'. (CVE-2014-9625)
- Multiple buffer overflow flaws exist in the mp4 demuxer due to improper parsing of string boxes. Specifically, these issues affect the 'MP4_ReadBox_name()' function in the source file 'modules/demux/libmp4.c'. (CVE-2014-9626, CVE-2014-9627, CVE-2014-9628)
- A buffer overflow exists in the Schroedinger encoder due to a flaw when calling 'memcpy'. Specifically, this issue affects the 'Encode()' function in the source file 'modules/codec/schroedinger.c'. Note: This issue also affects the Dirac encoder, which has been removed from VLC in version 2.1.6. (CVE-2014-9629)
- A heap-based buffer overflow flaw occurs due to invalid write access while streaming OGG files over RTP. Specifically, this affects the 'rtp_packetize_xiph_config()' function in the source file 'modules/stream_out/rtpfmt.c'. (CVE-2014-9630)
- Overflow conditions exist in the Ogg, AVI, ASF, TTA, and MP4 demuxers that are triggered as user-supplied input is not properly validated. With a specially crafted media file, a context-dependent attacker can cause heap-based buffer overflows, potentially allowing the execution of arbitrary code. (OSVDB 118919)
- An overflow condition exists in the 'Ogg_DecodePacket()' function in 'modules/demux/ogg.c'. The issue is triggered as user-supplied input is not properly validated when handling packet header size. This may allow a context-dependent attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (OSVDB 118682)
- An overflow condition exists that is triggered as user-supplied input is not properly validated when handling a WAV file. This may allow a context-dependent attacker to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (CVE-2016-3941)

Solution

Upgrade to VLC Media Player version 2.2.0 or later.

See Also

http://www.nessus.org/u?8e5f2d7e

https://www.videolan.org/security/sa1501.html

http://www.videolan.org/developers/vlc-branch/NEWS

http://www.videolan.org/vlc/releases/2.2.0.html

Plugin Details

Severity: High

ID: 9266

Family: Web Clients

Published: 2015/03/27

Modified: 2016/12/06

Dependencies: 9797

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2015/02/27

Vulnerability Publication Date: 2015/01/20

Reference Information

CVE: CVE-2014-9625, CVE-2014-9626, CVE-2014-9627, CVE-2014-9628, CVE-2014-9629, CVE-2014-9630, CVE-2016-3941

BID: 72252