PostgreSQL 9.3 < 9.3.10 / 9.4 < 9.4.5 DoS

Medium Nessus Network Monitor Plugin ID 9263


The database running on the remote server is affected by a denial of service vulnerability.


The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.10, or 9.4.x prior to 9.4.5 and is affected by a denial of service (DoS) vulnerability. This may allow an authenticated attacker to cause the server to crash when handling the specially crafted JSON request.


Upgrade to PostgreSQL 9.4.5, or later. If 9.4.x cannot be obtained, 9.3.10 is also patched for this vulnerability.

See Also

Plugin Details

Severity: Medium

ID: 9263

Family: Database

Published: 2016/04/22

Updated: 2019/03/06

Dependencies: 8705

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 6.4

Temporal Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2015/10/08

Vulnerability Publication Date: 2015/10/08

Reference Information

CVE: CVE-2015-5289

BID: 77048