PostgreSQL 9.3 < 9.3.10 / 9.4 < 9.4.5 DoS

Medium Nessus Network Monitor Plugin ID 9263

Synopsis

The database running on the remote server is affected by a denial of service vulnerability.

Description

The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.10, or 9.4.x prior to 9.4.5 and is affected by a denial of service (DoS) vulnerability. This may allow an authenticated attacker to cause the server to crash when handling the specially crafted JSON request.

Solution

Upgrade to PostgreSQL 9.4.5, or later. If 9.4.x cannot be obtained, 9.3.10 is also patched for this vulnerability.

See Also

http://www.postgresql.org/about/news/1615

http://seclists.org/bugtraq/2015/Oct/83

http://www.postgresql.org/docs/9.3/static/release-9-3-10.html

http://www.postgresql.org/docs/9.4/static/release-9-4-5.html

Plugin Details

Severity: Medium

ID: 9263

Family: Database

Published: 2016/04/22

Modified: 2016/04/22

Dependencies: 8705

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.4

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 6.4

Temporal Score: 6.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2015/10/08

Vulnerability Publication Date: 2015/10/08

Reference Information

CVE: CVE-2015-5289

BID: 77048