Oracle MySQL 5.5.x < 5.5.48 / 5.6.x < 5.6.29 / 5.7.x < 5.7.11 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9259

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is 5.5.x prior to 5.5.48, 5.6.x prior to 5.6.29, or 5.7.x prior to 5.7.11, and is affected by vulnerabilities in the following components :

- Data Manipulation Language
- Data Definition Language
- Full-Text Search
- MyISAM
- PeopleSoft
- Performance Schema
- Pluggable Authentication
- Replication
- Server Connection
- Server:Security
- Server:InnoDB
- Server:Optimizer
- Server:Options

Solution

Upgrade to MySQL 5.7.11 later. If 5.7.x cannot be obtained, 5.6.29 and 5.5.48 have also been patched for these vulnerabilities.

See Also

http://www.oracle.com/technetwork/security-advisory/cpuapr2016v3-2985753.html#AppendixMSQL

http://www.oracle.com/technetwork/topics/security/cpuapr2016-2881694.html

Plugin Details

Severity: Medium

ID: 9259

File Name: 9259.prm

Family: Database

Published: 2016/04/18

Modified: 2016/08/26

Dependencies: 8914

Nessus ID: 88698, 90833

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2015/12/03

Vulnerability Publication Date: 2015/12/03

Reference Information

CVE: CVE-2015-3194, CVE-2015-3195, CVE-2016-0640, CVE-2016-0641, CVE-2016-0644, CVE-2016-0646, CVE-2016-0649, CVE-2016-0650, CVE-2016-0653, CVE-2016-0654, CVE-2016-0656, CVE-2016-0658, CVE-2016-0661, CVE-2016-0663, CVE-2016-0665, CVE-2016-0668, CVE-2016-5444

BID: 78623, 78626, 86496