Oracle MySQL 5.7.x < 5.7.9 Insecure File Permissions

Low Nessus Network Monitor Plugin ID 9240

Synopsis

The remote database server is vulnerable to an information disclosure attack vector.

Description

The version of MySQL installed on the remote host is version 5.7.x prior to 5.7.9 and is affected by a flaw that is triggered as '/var/lib/mysql' creates files with insecure permissions. This may allow a local attacker to gain access to potentially sensitive information.

Solution

Upgrade to MySQL 5.7.9 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-9.html#mysqld-5-7-9-security

Plugin Details

Severity: Low

ID: 9240

Family: Database

Published: 2016/04/15

Modified: 2018/09/16

Dependencies: 8914

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.1

Temporal Score: 1.7

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4

Temporal Score: 3.7

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2015/10/21

Vulnerability Publication Date: 2015/10/21