Google Chrome < 49.0.2623.75 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9202

Synopsis

The remote host is utilizing a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is prior to 49.0.2623.75, and is affected by multiple vulnerabilities :

- Multiple overflow conditions exist in the libpng library in the 'png_set_PLTE()' and 'png_get_PLTE()' functions due to improper handling of bit depths less than eight. A remote attacker can exploit this, via a specially crafted PNG image, to cause a denial of service condition or the execution of arbitrary code. (CVE-2015-8126)
- An unspecified flaw exists in Blink that allows an attacker to bypass the same-origin policy. (CVE-2016-1630)
- An unspecified flaw exists in the Pepper plugin that allows an attacker to bypass the same-origin policy. (CVE-2016-1631)
- A bad cast flaw exists in the Extensions component that allows an attacker to have an unspecified impact. (CVE-2016-1632)
- Multiple use-after-free errors exist in Blink. A remote attacker can exploit these issues to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2016-1633, CVE-2016-1634, CVE-2016-1635)
- An unspecified flaw exists that allows an attacker to bypass SRI validation. (CVE-2016-1636)
- An unspecified flaw exists that allows an attacker to disclose sensitive information. (CVE-2016-1637)
- An unspecified flaw exists that allows an attacker to bypass the webAPI. (CVE-2016-1638)
- A use-after-free error exists in WebRTC. A remote attacker can exploit this issue to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2016-1639)
- An unspecified origin confusion flaw exists in the Extensions UI that allows an attacker to have an unspecified impact. (CVE-2016-1640)
- A use-after-free error exists in Favicon. A remote attacker can exploit this issue to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2016-1641)
- Multiple flaws exist that allow a remote attacker to execute arbitrary code. (CVE-2016-1642)
- Multiple unspecified flaws exist in Google V8 in 'runetime-scopes.cc' that allows an attacker to cause a denial of service condition or the execution of arbitrary code. (CVE-2016-2843)
- A bad cast flaw in 'layout/LayoutBlock.cpp' that is triggered as anonymous block wrappers are not properly removed from inline children allowing a context-dependent attacker to execute arbitrary code. (CVE-2016-2844)
- A flaw that is triggered as the path component of the URL is not properly validated when handling a response fetched via ServiceWoker. (CVE-2016-2845)

Solution

Update the Chrome browser to 49.0.2623.75 or later.

See Also

http://googlechromereleases.blogspot.com/2016/03/stable-channel-update.html

Plugin Details

Severity: High

ID: 9202

Family: Web Clients

Published: 2016/04/05

Modified: 2018/09/16

Dependencies: 4645

Nessus ID: 89685

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2016/03/02

Vulnerability Publication Date: 2015/11/13

Reference Information

CVE: CVE-2016-1630, CVE-2016-1631, CVE-2016-1632, CVE-2016-1633, CVE-2016-1634, CVE-2016-1635, CVE-2016-1636, CVE-2016-1637, CVE-2016-1638, CVE-2016-1639, CVE-2016-1640, CVE-2016-1641, CVE-2016-1642, CVE-2016-2843, CVE-2016-2844, CVE-2016-2845