PHP 5.6.x < 5.6.19 Denial of Service

Critical Nessus Network Monitor Plugin ID 9175

Synopsis

The remote web server uses a version of PHP that is affected by a Denial of Service (DoS) vulnerability.

Description

Versions of PHP 5.6.x prior to 5.6.19 are vulnerable to a NULL pointer dereference flaw in the 'xsl_ext_function_php()' function in 'ext/xsl/xsltprocessor.c'. This may potentially allow a remote attacker to cause a crash.

Solution

Upgrade to PHP version 5.6.19 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.5.33

http://www.php.net/ChangeLog-5.php#5.6.19

Plugin Details

Severity: Critical

ID: 9175

Family: Web Servers

Published: 2016/04/08

Modified: 2018/09/16

Dependencies: 8682

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2016/03/03

Vulnerability Publication Date: 2016/03/03