PHP 5.6.x < 5.6.19 / 7.0.x < 7.0.4 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 9172

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

Versions of PHP 5.6.x prior to 5.6.19, or 7.0.x prior to 7.0.4 are vulnerable to the following issues :

- A flaw exists in 'sapi/cli/php_cli_server.c' that is triggered as the built-in HTTP server does not properly restrict file requests. This may potentially allow a remote attacker to gain unauthorized access to arbitrary files. (OSVDB 135345)
- A use-after-free error exists in the Zend Opcache. The issue is triggered when updating cached directory names that have been cached in the current working directory. This may potentially allow a remote attacker to dereference already freed memory and potentially execute arbitrary code. (OSVDB 135346)
- A NULL pointer dereference flaw exists in the 'Zip::ExtractTo()' function in 'ext/zip/php_zip.c'. This may potentially allow a remote attacker to cause a crash. (OSVDB 135347)

Solution

Upgrade to PHP version 7.0.4 or later. If 7.x cannot be obtained, 5.6.19 is also patched for these vulnerabilities.

See Also

http://www.php.net/ChangeLog-5.php#5.6.19

http://www.php.net/ChangeLog-7.php#7.0.4

Plugin Details

Severity: Critical

ID: 9172

Family: Web Servers

Published: 2016/04/08

Modified: 2016/04/08

Dependencies: 8682, 9243

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2016/03/03

Vulnerability Publication Date: 2016/03/03