phpMyAdmin 4.4.x < 4.4.15.3 / 4.5.x < 4.5.4 Multiple Vulnerabilities (PMASA-2016-6, PMASA-2016-7)

Low Nessus Network Monitor Plugin ID 9116

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.4.x prior to 4.4.15.3, or 4.5.x prior to 4.5.4 are unpatched for the following vulnerabilities :

- An information disclosure vulnerability exists in the 'AES.php' and 'Rijndael.php' scripts that allows a remote attacker, via a specially crafted request, to disclose the software's installation path. (CVE-2016-2042)
- A cross-site scripting vulnerability exists due to improper validation of user-supplied input to the normalization script when handling a crafted table name before returning it to users. An authenticated, remote attacker can exploit this, via specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-2043)

Solution

Upgrade to phpMyAdmin 4.4.15.3 / 4.5.4 or later. Alternatively, apply the patch referenced in the vendor advisory.

See Also

https://www.phpmyadmin.net/security

https://www.phpmyadmin.net/security/PMASA-2016-6

https://www.phpmyadmin.net/security/PMASA-2016-7

Plugin Details

Severity: Low

ID: 9116

Family: CGI

Published: 2016/03/02

Modified: 2016/03/02

Dependencies: 9102

Nessus ID: 88986

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 3

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 3

Temporal Score: 2.8

Vector: CVSS3#AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2016/01/23

Vulnerability Publication Date: 2016/01/23

Reference Information

CVE: CVE-2016-2042, CVE-2016-2043

BID: 82097, 82101