phpMyAdmin 4.4.x < / 4.5.x < 4.5.4 Multiple Vulnerabilities (PMASA-2016-6, PMASA-2016-7)

Low Nessus Plugin ID 88986


The remote web server hosts a PHP application that is affected by multiple vulnerabilities.


According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.4.x prior to or 4.5.x prior to 4.5.4. It is, therefore, affected by the following vulnerabilities :

- An information disclosure vulnerability exists in the AES.php and Rijndael.php scripts that allows a remote attacker, via a specially crafted request, to disclose the software's installation path. (CVE-2016-2042)

- A cross-site scripting vulnerability exists due to improper validation of user-supplied input to the normalization script when handling a crafted table name before returning it to users. An authenticated, remote attacker can exploit this, via specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-2043)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to phpMyAdmin version / 4.5.4 or later.
Alternatively, apply the patch referenced in the vendor advisory.

See Also

Plugin Details

Severity: Low

ID: 88986

File Name: phpmyadmin_pmasa_2016_7.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2016/02/26

Updated: 2018/07/24

Dependencies: 17219

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2015/01/23

Vulnerability Publication Date: 2015/01/23

Reference Information

CVE: CVE-2016-2042, CVE-2016-2043

BID: 82097, 82101