phpMyAdmin 4.0.x < 4.0.10.9 / 4.2.x < 4.2.13.2 / 4.3.x < 4.3.11.1 Information Disclosure Vulnerability (PMASA-2015-1)

Medium Nessus Network Monitor Plugin ID 9103

Synopsis

The remote web server contains a PHP application that is affected by an information disclosure vulnerability.

Description

Versions of phpMyAdmin 4.0.x prior to 4.0.10.9, 4.2.x prior to 4.2.13.2, or 4.3.x prior to 4.3.11.1 are unpatched for an information disclosure vulnerability due to the length of compressed HTTPS responses not being hidden. This allows a remote attacker, using a series of crafted requests, to obtain the CSRF token via a BREACH attack.

Solution

Upgrade to phpMyAdmin 4.0.10.9 / 4.2.13.2 / 4.3.11.1 or later, or apply the patches referenced in the vendor advisory.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2015-1.php

http://www.nessus.org/u?a4cc2198

http://www.nessus.org/u?11d0e38d

http://www.nessus.org/u?4b01e679

Plugin Details

Severity: Medium

ID: 9103

Family: CGI

Published: 2016/02/25

Modified: 2018/09/16

Dependencies: 9102

Nessus ID: 81818

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2015/03/04

Vulnerability Publication Date: 2015/03/04

Reference Information

CVE: CVE-2015-2206

BID: 72949