phpMyAdmin 4.0.x < 4.0.10.9 / 4.2.x < 4.2.13.2 / 4.3.x < 4.3.11.1 Information Disclosure Vulnerability (PMASA-2015-1)

medium Nessus Plugin ID 81818
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server hosts a PHP application that is affected by an information disclosure vulnerability.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.0.x prior to 4.0.10.9, 4.2.x prior to 4.2.13.2, or 4.3.x prior to 4.3.11.1. It is, therefore, affected by an information disclosure vulnerability due to the length of compressed HTTPS responses not being hidden. This allows a remote attacker, using a series of crafted requests, to obtain the CSRF token via a BREACH attack.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin 4.0.10.9 / 4.2.13.2 / 4.3.11.1 or later, or apply the patches referenced in the vendor advisory.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2015-1.php

http://www.nessus.org/u?a4cc2198

http://www.nessus.org/u?11d0e38d

http://www.nessus.org/u?4b01e679

Plugin Details

Severity: Medium

ID: 81818

File Name: phpmyadmin_pmasa_2015_1.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 3/13/2015

Updated: 1/19/2021

Dependencies: phpMyAdmin_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 2.5

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 3/4/2015

Vulnerability Publication Date: 3/4/2015

Reference Information

CVE: CVE-2015-2206

BID: 72949