Mozilla Firefox < 44.0.2 Security Bypass Vulnerability

low Nessus Network Monitor Plugin ID 9077
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by a security bypass vulnerability.

Description

The version of Firefox installed is prior to 44.0.2 and is affected by a security bypass vulnerability due to improper restriction of interaction between service workers and plugins. An unauthenticated, remote attacker can exploit this using a crafted web site that triggers spoofed responses to requests that use NPAPI to bypass the same-origin policy. (CVE-2016-1949)

Solution

Upgrade to Firefox 44.0.2 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2016-14

Plugin Details

Severity: Low

ID: 9077

Family: Web Clients

Published: 2/19/2016

Updated: 3/6/2019

Dependencies: 9131

Nessus ID: 88752, 88754

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*

Patch Publication Date: 2/12/2016

Vulnerability Publication Date: 2/11/2016

Reference Information

CVE: CVE-2016-1949

BID: 82991