Apache Subversion 1.9.x < 1.9.3 Buffer Overflow

High Nessus Network Monitor Plugin ID 9069

Synopsis

The remote host is running a version of Apache Subversion (SVN) that is affected by a buffer overflow vulnerability.

Description

The version of Apache Subversion installed on the remote host is 1.9.x prior to 1.9.3 and is affected by a buffer overflow vulnerability. Specifically, these versions contain an overflow condition in the 'svn://' protocol parser. The issue is triggered as user-supplied input is not properly validated when handling 'svn://' protocol strings. This may allow a remote attacker to use a specially crafted request to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code.

Solution

Upgrade to Apache Subversion 1.9.3 or later.

See Also

http://subversion.apache.org/security

http://svn.apache.org/repos/asf/subversion/tags/1.9.3/CHANGES

http://subversion.apache.org/security/CVE-2015-5259-advisory.txt

Plugin Details

Severity: High

ID: 9069

Family: Web Servers

Published: 2016/02/05

Modified: 2018/09/16

Dependencies: 8971

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.6

Temporal Score: 8.2

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:subversion

Patch Publication Date: 2015/12/15

Vulnerability Publication Date: 2015/12/15

Reference Information

CVE: CVE-2015-5259

BID: 82300