PHP 5.6.x < 5.6.13 Use-After-Free Vulnerability

Critical Nessus Network Monitor Plugin ID 9066

Synopsis

The remote web server uses a version of PHP that is affected by a use-after-free vulnerability.

Description

Versions of PHP 5.6.x prior to 5.6.13 are vulnerable to a use-after-free error in the 'gmp_unserialize()' function in 'ext/gmp/gmp.c.' The issue is triggered as user-supplied input is not properly sanitized. This may allow a remote attacker to dereference already freed memory and potentially execute arbitrary code. (OSVDB 126960)

Solution

Upgrade to PHP 5.6.13, or later.

See Also

https://secure.php.net/ChangeLog-5.php#5.6.13

https://bugs.php.net/bug.php?id=70284

http://seclists.org/fulldisclosure/2015/Sep/26

Plugin Details

Severity: Critical

ID: 9066

File Name: 9066.prm

Family: Web Servers

Published: 2016/01/29

Modified: 2016/11/23

Dependencies: 8682

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2015/12/03

Vulnerability Publication Date: 2015/09/05