Adobe AIR < 19.0.0.241 Multiple Vulnerabilities (APSB15-28)

High Nessus Network Monitor Plugin ID 9042

Synopsis

The remote host is running an outdated version of Adobe AIR.

Description

Versions of Adobe AIR prior to 19.0.0.241 are outdated and thus unpatched for the following vulnerabilities :

- A type confusion error exists that allows an attacker to execute arbitrary code. (CVE-2015-7659)
- A security bypass vulnerability exists that allows an attacker to write arbitrary data to the file system under user permissions. (CVE-2015-7662)
- Multiple use-after-free vulnerabilities exist that allow an attacker to execute arbitrary code. (CVE-2015-7651, CVE-2015-7652, CVE-2015-7653, CVE-2015-7654, CVE-2015-7655, CVE-2015-7656, CVE-2015-7657, CVE-2015-7658, CVE-2015-7660, CVE-2015-7661, CVE-2015-7663, CVE-2015-8042, CVE-2015-8043, CVE-2015-8044, CVE-2015-8046)

Solution

Upgrade to Adobe AIR 19.0.0.241 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb15-28.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 9042

Family: Web Clients

Published: 2016/01/08

Modified: 2016/11/23

Dependencies: 4759

Nessus ID: 86850, 86853

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:ND/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:adobe_air

Patch Publication Date: 2015/11/10

Vulnerability Publication Date: 2015/11/10

Reference Information

CVE: CVE-2015-7651, CVE-2015-7652, CVE-2015-7653, CVE-2015-7654, CVE-2015-7655, CVE-2015-7656, CVE-2015-7657, CVE-2015-7658, CVE-2015-7659, CVE-2015-7660, CVE-2015-7661, CVE-2015-7662, CVE-2015-7663, CVE-2015-8042, CVE-2015-8043, CVE-2015-8044, CVE-2015-8046