Flash Player < 126.96.36.1997 Multiple Vulnerabilities (APSB16-01)
Critical Nessus Network Monitor Plugin ID 9041
SynopsisThe remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash Player prior to 188.8.131.527 are outdated and thus unpatched for the following vulnerabilities :
- A type confusion error exists that a remote attacker can exploit to execute arbitrary code. (CVE-2015-8644)
- An integer overflow condition exists that a remote attacker can exploit to execute arbitrary code. (CVE-2015-8651)
- Multiple use-after-free errors exist that a remote attacker can exploit to execute arbitrary code. (CVE-2015-8634, CVE-2015-8635, CVE-2015-8638, CVE-2015-8639, CVE-2015-8640, CVE-2015-8641, CVE-2015-8642, CVE-2015-8643, CVE-2015-8646, CVE-2015-8647, CVE-2015-8648, CVE-2015-8649, CVE-2015-8650)
- Multiple memory corruption issues exist that allow a remote attacker to execute arbitrary code. (CVE-2015-8459, CVE-2015-8460, CVE-2015-8636, CVE-2015-8645)
SolutionUpgrade to Adobe Flash Player version 184.108.40.2067 or later. If 20.x cannot be obtained, ESR version 220.127.116.114 has also been patched for these vulnerabilities.