Safari < 9.0.1 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 9028

Synopsis

The remote host has a web browser installed that is affected by multiple vulnerabilities.

Description

The version of Safari installed on the remote host is prior to 9.0.1, and is affected by multiple vulnerabilities in WebKit that are triggered as user-supplied input is not properly validated. With a specially crafted web page, a context-dependent attacker can potentially execute arbitrary code.

Solution

Upgrade to Safari version 9.0.1 or later.

See Also

https://support.apple.com/en-us/HT205377

Plugin Details

Severity: High

ID: 9028

Family: Web Clients

Published: 12/17/2015

Updated: 3/6/2019

Nessus ID: 86790

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*

Patch Publication Date: 10/21/2015

Vulnerability Publication Date: 10/21/2015

Reference Information

CVE: CVE-2015-5928, CVE-2015-5929, CVE-2015-5930, CVE-2015-5931, CVE-2015-7002, CVE-2015-7011, CVE-2015-7012, CVE-2015-7013, CVE-2015-7014

BID: 77264, 77267