Flash Player < 19.0.0.185 Multiple Vulnerabilities (APSB15-23)

High Nessus Network Monitor Plugin ID 9004

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.

Description

Versions of Adobe Flash Player prior to 19.0.0.185 are outdated and thus unpatched for the following vulnerabilities :

- An unspecified stack corruption issue exists that allows a remote attacker to execute arbitrary code. (CVE-2015-5567, CVE-2015-5579)
- A vector length corruption issue exists that allows a remote attacker to have an unspecified impact. (CVE-2015-5568)
- A use-after-free error exists in an unspecified component due to improperly sanitized user-supplied input. A remote attacker can exploit this, via a specially crafted file, to dereference already freed memory and execute arbitrary code. (CVE-2015-5570, CVE-2015-5574, CVE-2015-5581, CVE-2015-5584, CVE-2015-6682)
- An unspecified flaw exists due to a failure to reject content from vulnerable JSONP callback APIs. A remote attacker can exploit this to have an unspecified impact. (CVE-2015-5571)
- An unspecified flaw exists that allows a remote attacker to bypass security restrictions and gain access to sensitive information. (CVE-2015-5572)
- An unspecified type confusion flaw exists that allows a remote attacker to execute arbitrary code. (CVE-2015-5573)
- A flaw exists in an unspecified component due to improper validation of user-supplied input when handling a specially crafted file. A remote attacker can exploit this to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2015-5575, CVE-2015-5577, CVE-2015-5578, CVE-2015-5580, CVE-2015-5582, CVE-2015-5588, CVE-2015-6677)
- A memory leak issue exists that allows a remote attacker to have an unspecified impact. (CVE-2015-5576)
- A stack buffer overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-5587)
- An unspecified overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-6676, CVE-2015-6678)
- An unspecified flaw exists that allows a remote attacker to bypass same-origin policy restrictions and gain access to sensitive information. (CVE-2015-6679)

Solution

Upgrade to Adobe Flash Player version 19.0.0.185 or later. If 19.x cannot be obtained, ESR version 18.0.0.241 has also been patched for these vulnerabilities.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb15-23.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 9004

Family: Web Clients

Published: 2015/10/21

Modified: 2015/10/21

Dependencies: 5158

Nessus ID: 86060, 86063

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2015/09/21

Vulnerability Publication Date: 2015/09/21

Reference Information

CVE: CVE-2015-5567, CVE-2015-5568, CVE-2015-5570, CVE-2015-5571, CVE-2015-5572, CVE-2015-5573, CVE-2015-5574, CVE-2015-5575, CVE-2015-5576, CVE-2015-5577, CVE-2015-5578, CVE-2015-5579, CVE-2015-5580, CVE-2015-5581, CVE-2015-5582, CVE-2015-5584, CVE-2015-5587, CVE-2015-5588, CVE-2015-6676, CVE-2015-6677, CVE-2015-6678, CVE-2015-6679, CVE-2015-6682