PHP 5.6.x < 5.6.12 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 8960


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


Versions of PHP 5.6.x earlier than 5.6.12 are vulnerable to the following issues :

- A flaw exists in the file 'gd.c' due to the improper handling of images with large negative coordinates by the imagefilltoborder() function. An attacker can exploit this to cause a stack overflow, thus crashing an application using PHP.
- A flaw exists in the file 'php_odbc.c' when the odbc_fetch_array() function handles columns that are defined as NVARCHAR(MAX). An attacker can exploit this to crash an application using PHP.


Upgrade to PHP version 5.6.12 or later.

See Also

Plugin Details

Severity: High

ID: 8960

Family: Web Servers

Published: 10/8/2015

Updated: 3/6/2019

Nessus ID: 85300

Risk Information


Risk Factor: High

Base Score: 7.1

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Risk Factor: High

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 8/6/2015

Vulnerability Publication Date: 1/2/2014

Reference Information

CVE: CVE-2015-6831, CVE-2015-6832, CVE-2015-6833, CVE-2015-8867, CVE-2015-8874, CVE-2015-8879