PHP 5.5.x < 5.5.27 / 5.6.x < 5.6.11 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8955


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


Versions of PHP 5.5.x earlier than 5.5.27, or 5.6.x earlier than 5.6.11 are vulnerable to the following issues :

A double-free flaw exists in zend_vm_execute.h due to improper handling of certain code. An attacker can exploit this flaw to crash a PHP application, resulting in a denial of service condition.
- A flaw exists in the parse_ini_file() and parse_ini_string() functions. Due to improper handling of strings that contain a line feed followed by an escape character, an attacker can exploit this to crash a PHP application, resulting in a denial of service condition.


Upgrade to PHP version 5.6.11 or later. If 5.6.11 cannot be installed, 5.5.27 is also patched for this vulnerability.

See Also

Plugin Details

Severity: High

ID: 8955

Family: Web Servers

Published: 2015/10/07

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 84672, 84673

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2015/07/09

Vulnerability Publication Date: 2015/05/30

Reference Information

CVE: CVE-2015-3152, CVE-2015-5589, CVE-2015-5590, CVE-2015-8838