Apache HTTP Server 2.4.10 FastCGI DoS
Medium Nessus Network Monitor Plugin ID 8938
SynopsisThe remote web server is missing an Apache HTTP Server patch update.
DescriptionThe version of Apache HTTP Server 2.4 installed on the remote host is 2.4.10 and is, therefore, affected by a denial of service. Specifically, the 'mod_proxy_fcgi' module allows a remote FastCGI server to cause a buffer overflow and crash the HTTP daemon. This is caused by a flaw in the way that Apache HTTP Server handles long response headers. An attacker, exploiting this flaw, would be able to cause a denial of service on the Apache HTTP Server.
SolutionUpgrade to Apache HTTP Server version 2.4.11 or later.