Apache HTTP Server 2.4.10 FastCGI DoS

Medium Nessus Network Monitor Plugin ID 8938


The remote web server is missing an Apache HTTP Server patch update.


The version of Apache HTTP Server 2.4 installed on the remote host is 2.4.10 and is, therefore, affected by a denial of service. Specifically, the 'mod_proxy_fcgi' module allows a remote FastCGI server to cause a buffer overflow and crash the HTTP daemon. This is caused by a flaw in the way that Apache HTTP Server handles long response headers. An attacker, exploiting this flaw, would be able to cause a denial of service on the Apache HTTP Server.


Upgrade to Apache HTTP Server version 2.4.11 or later.

See Also


Plugin Details

Severity: Medium

ID: 8938

Family: Web Servers

Published: 2015/02/27

Modified: 2018/09/16

Dependencies: 8947

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Patch Publication Date: 2014/12/15

Vulnerability Publication Date: 2014/12/15

Reference Information

CVE: CVE-2014-3583

BID: 71657