Apache Tomcat 7.0.x < 7.0.53 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 8935
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is missing an Apache Tomcat patch update.

Description

The version of Apache Tomcat installed on the remote host is version 7.x prior to 7.0.53. It is, therefore, affected by the following vulnerabilities:

- An error exists related to chunk size and chunked requests that could allow denial of service attacks. (CVE-2014-0075)

- An error exists related to XSLT handling and security managers that could allow security bypass related to external XML entities. (CVE-2014-0096)

- An error exists related to content length header handling and using the application behind a reverse proxy that could allow security bypass. (CVE-2014-0099)

Solution

Update to Apache Tomcat version 7.0.53 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.53

Plugin Details

Severity: Medium

ID: 8935

Family: Web Servers

Published: 3/2/2015

Updated: 5/20/2019

Nessus ID: 74246

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 5/31/2014

Vulnerability Publication Date: 5/31/2014

Reference Information

CVE: CVE-2014-0075, CVE-2014-0096, CVE-2014-0099

BID: 67667, 67668, 67671

IAVB: 2015-B-0083