Oracle MySQL 5.6.x < 5.6.20 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8917

Synopsis

The remote database server is missing a critical Oracle MySQL patch update.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.20. It is, therefore, affected by errors in the following components :

- SERVER:SP (CVE-2014-6489)
- SERVER INNODB FULLTEXT SEARCH (CVE-2014-6564)
- SERVER:MEMCACHED (CVE-2014-6474)

Solution

Upgrade to MySQL 5.6.20 or later.

See Also

http://www.oracle.com/technetwork/topics/security/cpuoct2014-1972960.html

Plugin Details

Severity: Medium

ID: 8917

Family: Database

Published: 2015/02/24

Modified: 2016/01/15

Dependencies: 8914

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.4

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2014/10/28

Vulnerability Publication Date: 2014/10/28

Reference Information

CVE: CVE-2014-6489, CVE-2014-6564, CVE-2014-6474

BID: 70525, 70511, 70448