Oracle MySQL 5.6.x < 5.6.19 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8910

Synopsis

The remote database server is missing a critical Oracle MySQL patch update.

Description

The Oracle MySQL database installed on the remote host is version 5.6 prior to 5.6.19 and is, therefore, affected by multiple vulnerabilities. The components affected by these vulnerabilities are:

- SROPTZR (CVE-2014-2484, CVE-2014-4238)
- SRSP (CVE-2014-4214)
- SRREP (CVE-2014-4233, CVE-2014-4240)
- SRINFOSC (CVE-2014-4258)
- SRCHAR (CVE-2014-4260)

Solution

Upgrade to MySQL 5.6.19 or later.

See Also

http://www.nessus.org/u?7de2f8eb

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-19.html

http://www.oracle.com/technetwork/topics/security/cpujul2014-1972956.html

Plugin Details

Severity: Medium

ID: 8910

Family: Database

Published: 2015/02/24

Modified: 2018/09/16

Dependencies: 8914

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 6

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2014/07/17

Vulnerability Publication Date: 2014/07/17

Reference Information

CVE: CVE-2014-2484, CVE-2014-4214, CVE-2014-4233, CVE-2014-4238, CVE-2014-4240, CVE-2014-4258, CVE-2014-4260

BID: 68560, 68564, 68573, 68587, 68598, 68602, 68607