cURL / libcURL 7.x < 7.42.1 Proxied Traffic HTTP Server Header Remote Disclosure

Medium Nessus Network Monitor Plugin ID 8864

Synopsis

The cURL program is a library and command-line tool for transferring data using various protocols, including HTTP, FTP, and LDAP. A vulnerable version of cURL was detected from the host.

Description

cURL and libcurl before 7.42.0 are unpatched for a flaw due to the program transmitting sensitive HTTP server headers within proxied traffic to the server allowing a remote attacker, with access to the proxy, to gain access to potentially sensitive information.

Solution

Upgrade to cURL/libcURL 7.42.1 or later.

See Also

http://curl.haxx.se/docs/adv_20150429.html

Plugin Details

Severity: Medium

ID: 8864

Family: Web Clients

Published: 2015/09/15

Modified: 2015/09/15

Dependencies: 1735, 8314

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:ND/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:haxx:curl

Patch Publication Date: 2015/04/29

Vulnerability Publication Date: 2015/04/29

Reference Information

CVE: CVE-2015-3153

BID: 74408