Apache Tomcat 7.0.x < 7.0.55 / 8.0.x < 8.0.9 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 8831


The remote Apache Tomcat server is affected by multiple vulnerabilities.


Apache Tomcat 7.0.x before 7.0.55 or 8.0.x before 8.0.9 is affected by multiple vulnerabilities:

- A flaw in handling attempts to continue reading data after an error has occurred, which allows remote attackers to conduct HTTP request smuggling attacks or cause a denial of service by streaming data with malformed chunked transfer coding. (CVE-2014-0227)

- A flaw in handling an aborted file upload after it has partially been completed may allow a remote attacker to exhaust available memory resources. (CVE-2014-0230)


Upgrade to Apache Tomcat version 7.0.55 or 8.0.9 or later.

See Also



Plugin Details

Severity: Medium

ID: 8831

Family: Web Servers

Published: 7/24/2015

Updated: 5/20/2019

Dependencies: 8928, 8931

Nessus ID: 77475, 81580

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 11/22/2014

Vulnerability Publication Date: 2/15/2015

Reference Information

CVE: CVE-2014-0230, CVE-2014-0227

BID: 72717, 74475