Flash Player < 184.108.40.2061 / 220.127.116.11 Multiple Vulnerabilities (APSB15-06)
High Nessus Network Monitor Plugin ID 8815
SynopsisThe remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash Player prior to 18.104.22.168 are outdated and thus unpatched for the following vulnerabilities :
- Multiple double-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0346, CVE-2015-0359)
- Multiple memory corruption flaws exist due to improper validation of user-supplied input. A remote attacker can exploit these flaws, via specially crafted flash content, to corrupt memory and execute arbitrary code. (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043)
- A unspecified buffer overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-0348)
- Multiple unspecified use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039)
- An unspecified type confusion flaw exists that allows an attacker to execute arbitrary code. (CVE-2015-0356)
- Multiple unspecified memory leaks exist that allows an attacker to bypass the Address Space Layout Randomization (ASLR) feature. (CVE-2015-0357, CVE-2015-3040)
- An unspecified security bypass flaw exists that allows an attacker to disclose information. (CVE-2015-3044)
SolutionUpgrade to Adobe Flash Player version 22.214.171.124 or later. Alternatively, Adobe has made version 126.96.36.1991 available for those installs that cannot be upgraded to 17.x.