Google Android Operating System < 4.3.0 Multiple Vulnerabilities

Low Nessus Network Monitor Plugin ID 8781

Synopsis

The remote mobile device is affected by multiple vulnerabilities.

Description

Versions of the Google Android operating system earlier than 4.3.0 are outdated and thus unpatched for the following vulnerabilities:

- A flaw in the tethering function is triggered when responding to recursive DNS queries that are received and referred to as an open resolver. This may allow a remote attacker to conduct DNS amplification attacks, allowing them to leverage the device to perform DDoS attacks against other targets.
- A flaw in 'BackupManagerService' does not properly sanitize user input, specifically path traversal style attacks (e.g. '../') when extracting TAR files. With a specially crafted application, a local attacker can overwrite arbitrary files. (CVE-2014-7951)

Solution

Upgrade to Google Android version 4.3.0 or later.

See Also

http://seclists.org/fulldisclosure/2015/Apr/51

http://jvndb.jvn.jp/en/contents/2015/JVNDB-2015-000045.html

Plugin Details

Severity: Low

ID: 8781

Published: 2015/06/26

Modified: 2018/09/16

Dependencies: 5287

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:U/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:P/RL:U/RC:C

Vulnerability Information

CPE: cpe:/o:google:android

Patch Publication Date: 2014/05/15

Vulnerability Publication Date: 2015/03/31

Reference Information

CVE: CVE-2014-7951

BID: 74211, 74888