Oracle MySQL 5.5.x < 5.5.43 / 5.6.x < 5.6.24 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 8761

Synopsis

The remote database server is missing a critical Oracle MySQL patch update.

Description

The version of MySQL installed on the remote host is version 5.5.x prior to 5.5.43 or 5.6.x prior to 5.6.24. It is, therefore, affected by errors in the following components :

- Server : Optimizer (CVE-2015-2571)

- Server : DDL (CVE-2015-0505)

- Server : Federated (CVE-2015-0499)

- Server : Compiling (CVE-2015-0501)

Solution

Upgrade to MySQL 5.5.43, 5.6.24, or later.

See Also

http://www.nessus.org/u?c4f2e20f

http://www.nessus.org/u?e75fe00b

Plugin Details

Severity: Medium

ID: 8761

Family: Database

Published: 5/7/2015

Updated: 3/6/2019

Dependencies: 8914

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.7

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:M/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 4.4

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:*

Patch Publication Date: 4/14/2015

Vulnerability Publication Date: 4/14/2015

Reference Information

CVE: CVE-2015-0499, CVE-2015-0501, CVE-2015-0505, CVE-2015-2571

BID: 74070, 74095, 74112, 74115

IAVA: 2015-A-0085