PostgreSQL 9.0 < 9.0.19 / 9.1 < 9.1.15 / 9.2 < 9.2.10 / 9.3 < 9.3.6 / 9.4 < 9.4.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8727

Synopsis

The database running on the remote server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 9.0.x prior to 9.0.19, 9.1.x prior to 9.1.15, 9.2.x prior to 9.2.10, 9.3.x prior to 9.3.6, or 9.4.x prior to 9.4.1 and is affected by multiple vulnerabilities :

- A privilege escalation vulnerability exists due to the 'make check' command not properly invoking initdb to specify authentication requirements for a database cluster to be used for tests. (CVE-2014-0067)

- An information disclosure vulnerability exists due to improper handling of restricted column values in constraint-violation error messages. (CVE-2014-8161)

- Multiple vulnerabilities exist due to several buffer overflow errors related to the 'to_char' functions. (CVE-2015-0241)

- Multiple vulnerabilities exist due to several stack-based buffer overflow errors in various '*printf()' functions. The overflows are due to improper validation of user-supplied input when formatting a floating point number where the requested precision is greater than approximately 500. (CVE-2015-0242)

- Multiple vulnerabilities exist due to an overflow condition in multiple functions in the 'pgcrypto' extension. The overflows are due to improper validation of user-supplied input when tracking memory sizes. (CVE-2015-0243)

- A SQL injection vulnerability exists due to improper sanitization of user-supplied input when handling crafted binary data within a command parameter.(CVE-2015-0244)

Solution

Upgrade to PostgreSQL 9.0.19 / 9.1.15 / 9.2.10 / 9.3.6 / 9.4.1, or later.

See Also

http://www.postgresql.org/about/news/1569/

http://www.postgresql.org/docs/9.0/static/release-9-0-19.html

http://www.postgresql.org/docs/9.1/static/release-9-1-15.html

http://www.postgresql.org/docs/9.2/static/release-9-2-10.html

http://www.postgresql.org/docs/9.3/static/release-9-3-6.html

http://www.postgresql.org/docs/9.4/static/release-9-4-1.html

Plugin Details

Severity: High

ID: 8727

Family: Database

Published: 2015/04/24

Modified: 2016/02/05

Dependencies: 8705

Nessus ID: 81300

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.7

Temporal Score: 8.3

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2015/02/05

Vulnerability Publication Date: 2015/02/05

Reference Information

CVE: CVE-2014-0067, CVE-2014-8161, CVE-2015-0241, CVE-2015-0242, CVE-2015-0243, CVE-2015-0244

BID: 65721, 72538, 72540, 72542, 72543, 74174