Mozilla Firefox < 36.0.3 / Firefox ESR < 31.5.2 JIT Code Execution

High Nessus Network Monitor Plugin ID 8688

Synopsis

The remote host has a web browser that is affected by a remote code execution vulnerability.

Description

Versions of Mozilla Firefox earlier than 36.0.3 (or ESR version 31.5.2) are affected by a remote code execution vulnerability due to an out-of-bounds error in typed array bounds checking within 'asmjs/AsmJSValidate.cpp', which relates to just-in-time compilation for JavaScript. A remote attacker, using a specially crafted web page, can exploit this to execute arbitrary code by reading and writing to memory.

Solution

Upgrade to Firefox 36.0.3 (or Firefox ESR version 31.5.2, as appropriate), or later.

See Also

https://www.mozilla.org/security/announce/2014/mfsa2015-25.html

https://www.mozilla.org/security/announce/2014/mfsa2015-26.html

https://www.mozilla.org/security/announce/2014/mfsa2015-27.html

Plugin Details

Severity: High

ID: 8688

Family: Web Clients

Published: 2015/04/10

Modified: 2016/03/07

Dependencies: 9131

Nessus ID: 82038, 82040

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Patch Publication Date: 2015/03/20

Vulnerability Publication Date: 2015/03/20

Reference Information

CVE: CVE-2015-0817

BID: 73263