Mozilla Firefox < 36.0.4 / Firefox ESR < 31.5.3 SVG Bypass Privilege Escalation

High Nessus Network Monitor Plugin ID 8685

Synopsis

The remote Windows host contains a web browser that is affected by a privilege escalation vulnerability.

Description

Versions of Mozilla Firefox earlier than 36.0.4 (or ESR version 31.5.3) are affected by a privilege escalation vulnerability due to a flaw within 'docshell/base/nsDocShell.cpp', which relates to SVG format content navigation. A remote attacker can exploit this to bypass same-origin policy protections, allowing a possible execution of arbitrary scripts in a privileged context.

Solution

Upgrade to Firefox 36.0.4 (or Firefox ESR version 31.5.3, as appropriate), or later.

See Also

https://www.mozilla.org/security/announce/2014/mfsa2015-25.html

https://www.mozilla.org/security/announce/2014/mfsa2015-26.html

https://www.mozilla.org/security/announce/2014/mfsa2015-27.html

Plugin Details

Severity: High

ID: 8685

Family: Web Clients

Published: 2015/04/10

Modified: 2016/03/07

Dependencies: 9131

Nessus ID: 82039, 82041

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Patch Publication Date: 2015/03/21

Vulnerability Publication Date: 2015/03/20

Reference Information

CVE: CVE-2015-0818

BID: 73265