OpenSSL <= 0.9.8f DoS

medium Nessus Network Monitor Plugin ID 8663


The remote web server is running an outdated instance of OpenSSL which is prone to a denial of service vulnerability.


According to its banner, the remote host is running a version of OpenSSL older than 0.9.8g. Such versions are prone to a denial of service vulnerability due to an error in the 'hostname' TLS extension. Specifically, the issue affects the 'ssl/ssl_lib.c' source file. An attacker can exploit this issue to cause a memory access violation, potentially crashing the service and denying access to legitimate users.


Upgrade to OpenSSL 0.9.8g or later.

See Also

Plugin Details

Severity: Medium

ID: 8663

Family: Web Servers

Published: 3/27/2015

Updated: 3/6/2019

Risk Information


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

Patch Publication Date: 2/23/2009

Vulnerability Publication Date: 3/19/2015

Reference Information

CVE: CVE-2009-5146

BID: 73121